Please support this Forum and Neven's Blog

Author Topic: [Solved] How to embed a video ?  (Read 13492 times)

ivica

  • ASIF Middle Class
  • Posts: 512
  • Kelele
    • View Profile
[Solved] How to embed a video ?
« on: February 21, 2013, 05:59:54 PM »
A trick from other forum do not works:
[youtube]a_video_id[/youtube]

Possible solution #1: (for mods)
"Two huge media mods: Gallery, and Auto-embedder for 200+ sites like YouTube, DailyMotion, etc."
http://custom.simplemachines.org/mods/index.php?mod=977

Possible solution #2:
"How to embed YouTube vids, without needing a mod."
http://www.simplemachines.org/community/index.php?topic=418556.msg2924566#msg2924566

Example as per above
<a href="http://www.youtube.com/v/MR8_U5632as&amp;feature=youtu.be" target="_blank" class="new_win">http://www.youtube.com/v/MR8_U5632as&amp;feature=youtu.be</a>
do not work.
Possible solution for it, we need mod:
Admin -> Posts and topics -> Post Settings -> Embed flash into posts

Any other ideas?
« Last Edit: February 25, 2013, 08:29:33 AM by ivica »

Neven

  • Administrator
  • ASIF Governor
  • *****
  • Posts: 3847
    • View Profile
    • Arctic Sea Ice Blog
Re: How to embed a video ?
« Reply #1 on: February 21, 2013, 06:08:55 PM »
Hi Ivica,

I changed the setting (didn't do it before, because it said: "may be a security risk!"). Does it work now?
Il faut cultiver notre jardin

ivica

  • ASIF Middle Class
  • Posts: 512
  • Kelele
    • View Profile
Re: How to embed a video ?
« Reply #2 on: February 21, 2013, 06:18:49 PM »
Nope.
Apparently, a space for video window is reserved but nothing happens there.
BTW: Can we have more Emoticons (smiley..) ?

Neven

  • Administrator
  • ASIF Governor
  • *****
  • Posts: 3847
    • View Profile
    • Arctic Sea Ice Blog
Re: How to embed a video ?
« Reply #3 on: February 21, 2013, 06:25:56 PM »
I could install this AEVA mod, but would have to ask DungeonMaster first. He is after all the master of this here dungeon.

Wait a minute, there's a flash button in the WYSIWYG editor now.

Let me try:

<a href="http://www.youtube.com/v/=xm2PM33w23Q" target="_blank" class="new_win">http://www.youtube.com/v/=xm2PM33w23Q</a>

No, not working either...

Il faut cultiver notre jardin

Neven

  • Administrator
  • ASIF Governor
  • *****
  • Posts: 3847
    • View Profile
    • Arctic Sea Ice Blog
Re: How to embed a video ?
« Reply #4 on: February 21, 2013, 06:34:30 PM »
I don't know how to make the smiley set larger, but it's okay like this, no?
Il faut cultiver notre jardin

ivica

  • ASIF Middle Class
  • Posts: 512
  • Kelele
    • View Profile
Re: How to embed a video ?
« Reply #5 on: February 21, 2013, 06:45:20 PM »
Humans are emotional creatures, no set can full-fill the need. So, it will be OK.
For a while... ;)

DungeonMaster

  • Administrator
  • ASIF Citizen
  • *****
  • Posts: 123
    • View Profile
Re: How to embed a video ?
« Reply #6 on: February 21, 2013, 06:46:18 PM »
Ivica's video appears here, so I don't really know what happens. I'll check when I leave the train ;)
This forum helps me to feel less uncomfortable about "doing something" about the melting Arctic and the warming world.
Read again  Maslowski paper : why Arctic could melt in 2016 +/- 3Y !

Artful Dodger

  • ASIF Citizen
  • Posts: 436
  • The era of procrastination is coming to a close.
    • View Profile
Re: How to embed a video ?
« Reply #7 on: February 21, 2013, 07:29:15 PM »
EDIT Feb 24, 2013: Thanks for applying the BB patch, Neven!
It's working now!  :D

Problem: You want to embed this YouTube video:



What's the secret?

You put just the X8iUXX-JT90 between the |youtube| tags

[youtube]X8iUXX-JT90[/youtube]



To send someone a SPECIFIC SPOT in a YouTube video, add a suffix with the minute and second of that spot.

If the specific spot on the youtube was at the 2 minute and 34 second spot, the suffix would add to the end of the normal address is #t=2m34
« Last Edit: February 24, 2013, 08:10:59 PM by Artful Dodger »
Cheers!
Lodger

Neven

  • Administrator
  • ASIF Governor
  • *****
  • Posts: 3847
    • View Profile
    • Arctic Sea Ice Blog
Re: How to embed a video ?
« Reply #8 on: February 21, 2013, 07:31:35 PM »
Nice try, Lodger!  ;D

I'm seeing white squares in FireFox, but nada in Chrome.
Il faut cultiver notre jardin

ivica

  • ASIF Middle Class
  • Posts: 512
  • Kelele
    • View Profile
Re: How to embed a video ?
« Reply #9 on: February 21, 2013, 07:43:10 PM »
Yup, Chrome here too...

Artful Dodger

  • ASIF Citizen
  • Posts: 436
  • The era of procrastination is coming to a close.
    • View Profile
Re: How to embed a video ?
« Reply #10 on: February 21, 2013, 07:53:41 PM »
Nice try, Lodger!  ;D

You're Welcome, Neven!  :D



The syntax I posted above is correct, however the site Administrator needs to install a Package from the Admin Panel before videos will work.

Here's how to do that from the SMF Online Manual:

http://www.simplemachines.org/community/index.php?topic=384047.0
« Last Edit: February 26, 2013, 03:44:05 AM by Artful Dodger »
Cheers!
Lodger

DungeonMaster

  • Administrator
  • ASIF Citizen
  • *****
  • Posts: 123
    • View Profile
Re: How to embed a video ?
« Reply #11 on: February 24, 2013, 07:38:44 PM »
Sorry for the delay guys, first I wanted to be sure that it works - this Mod isn't maintained anymore, it seems that the developper had some trouble with the SMF team.

Anyway it should work... So I post this famous video from UberPoster Doctor Inferno

(I just pasted the url for the video from the Address Bar, nothing more - then some magic happened)

Squirrels play the banjo
« Last Edit: February 24, 2013, 07:41:36 PM by DungeonMaster »
This forum helps me to feel less uncomfortable about "doing something" about the melting Arctic and the warming world.
Read again  Maslowski paper : why Arctic could melt in 2016 +/- 3Y !

ivica

  • ASIF Middle Class
  • Posts: 512
  • Kelele
    • View Profile
Re: How to embed a video ?
« Reply #12 on: February 24, 2013, 07:48:18 PM »
No magic here :(

Space for window reserved but nothing happens.


EDIT:
Above is valid for Chrome and an old Enigma.

I saw video under an old Firefox.
« Last Edit: February 24, 2013, 07:51:23 PM by ivica »

DungeonMaster

  • Administrator
  • ASIF Citizen
  • *****
  • Posts: 123
    • View Profile
Re: How to embed a video ?
« Reply #13 on: February 24, 2013, 07:51:23 PM »
No magic here :(

Space for window reserved but nothing happens.
Have you tried copying a fresh address from your browser ? or did you try to edit your first message ?
This forum helps me to feel less uncomfortable about "doing something" about the melting Arctic and the warming world.
Read again  Maslowski paper : why Arctic could melt in 2016 +/- 3Y !

ivica

  • ASIF Middle Class
  • Posts: 512
  • Kelele
    • View Profile
Re: How to embed a video ?
« Reply #14 on: February 24, 2013, 07:53:31 PM »
Please, wait a minute...
RETESTING

ivica

  • ASIF Middle Class
  • Posts: 512
  • Kelele
    • View Profile
Re: How to embed a video ?
« Reply #15 on: February 24, 2013, 07:57:16 PM »

Works for: IE, Firefox

Does not work for: Chrome, Enigma

DungeonMaster

  • Administrator
  • ASIF Citizen
  • *****
  • Posts: 123
    • View Profile
Re: How to embed a video ?
« Reply #16 on: February 24, 2013, 07:59:15 PM »
Same here, doesn't work with Chrome (I'm running linux). Let me see...
This forum helps me to feel less uncomfortable about "doing something" about the melting Arctic and the warming world.
Read again  Maslowski paper : why Arctic could melt in 2016 +/- 3Y !

ivica

  • ASIF Middle Class
  • Posts: 512
  • Kelele
    • View Profile
Re: How to embed a video ?
« Reply #17 on: February 24, 2013, 08:09:27 PM »
Nothing new.
Copy/paste of a video url
Works for IE/Firefox.
not for Chrome, Enigma.

OS: Win XP

DungeonMaster

  • Administrator
  • ASIF Citizen
  • *****
  • Posts: 123
    • View Profile
Re: How to embed a video ?
« Reply #18 on: February 24, 2013, 08:28:47 PM »
Ok I've found a path to explore, seems to be a (what chrome thinks to be a) security issue. I'm going to follow this...

Edit : Yep, Chrome is angry when we mix content form a secure page (https) and unsecure (http). So you can either use the forum in http mode (which is not a problem if you're not connected), OR bypass by clicking the "Shield" icon in Chrome's address bar. At least it worked here. Ivica (and others) can you please try and confirm ?
« Last Edit: February 24, 2013, 08:36:05 PM by DungeonMaster »
This forum helps me to feel less uncomfortable about "doing something" about the melting Arctic and the warming world.
Read again  Maslowski paper : why Arctic could melt in 2016 +/- 3Y !

ivica

  • ASIF Middle Class
  • Posts: 512
  • Kelele
    • View Profile
Re: How to embed a video ?
« Reply #19 on: February 24, 2013, 08:50:06 PM »
HTTP confirmed

... stay tuned ... testing..

SHIELD confirmed.

DungeonMaster, Bravo!

« Last Edit: February 24, 2013, 08:56:22 PM by ivica »

DungeonMaster

  • Administrator
  • ASIF Citizen
  • *****
  • Posts: 123
    • View Profile
Re: How to embed a video ?
« Reply #20 on: February 24, 2013, 08:55:49 PM »
OK, that's half the way.

Now I have to find a way to make the site work with http only AND provide good security (tip: will search for a SSO solution - first I have to test it...)
This forum helps me to feel less uncomfortable about "doing something" about the melting Arctic and the warming world.
Read again  Maslowski paper : why Arctic could melt in 2016 +/- 3Y !

Neven

  • Administrator
  • ASIF Governor
  • *****
  • Posts: 3847
    • View Profile
    • Arctic Sea Ice Blog
Re: [Solved] How to embed a video ?
« Reply #21 on: February 25, 2013, 01:13:39 PM »
Great stuff, DM!

Re Klapa Sinj: Sinj is real close to my grandfather's village.  :)
Il faut cultiver notre jardin

ivica

  • ASIF Middle Class
  • Posts: 512
  • Kelele
    • View Profile
Re: [Solved] How to embed a video ?
« Reply #22 on: February 25, 2013, 01:34:08 PM »
 :)

ccgwebmaster

  • ASIF Upper Class
  • Posts: 1085
  • Civilisation collapse - what are you doing?
    • View Profile
    • CCG Website
Re: [Solved] How to embed a video ?
« Reply #23 on: August 16, 2013, 10:42:57 PM »
I thought video embedding was working - at least - I used to see plenty of video clips (eg to Youtube embedded within posts).

Now I just see a reserved blank spot - in Firefox? Did something stop working or get switched off? Or is it just me?

retiredbill

  • ASIF Lurker
  • Posts: 26
    • View Profile
Re: [Solved] How to embed a video ?
« Reply #24 on: August 17, 2013, 12:32:05 PM »
I thought video embedding was working - at least - I used to see plenty of video clips (eg to Youtube embedded within posts).

Now I just see a reserved blank spot - in Firefox? Did something stop working or get switched off? Or is it just me?

I'm using Firefox (22.0) and I can view the video in #19 above just fine...

ccgwebmaster

  • ASIF Upper Class
  • Posts: 1085
  • Civilisation collapse - what are you doing?
    • View Profile
    • CCG Website
Re: [Solved] How to embed a video ?
« Reply #25 on: August 17, 2013, 06:53:40 PM »
I'm using Firefox (22.0) and I can view the video in #19 above just fine...

Thanks. Traced it to HTTPS. Removing the HTTPS means clips show again apparently.

Jim Hunt

  • ASIF Governor
  • Posts: 3106
    • View Profile
    • The Arctic sea ice Great White Con
Re: [Solved] How to embed a video ?
« Reply #26 on: October 30, 2013, 12:28:22 PM »
Not entirely [Solved], for flash at least. I just tried embedding a .SWF for the first time as follows:

<a href="http://icue.nbcunifiles.com/icue/files/nbclearn/site/video/widget/NBC_Learn_Video_Widget.swf?VIDEO_ID=1280886" target="_blank" class="new_win">http://icue.nbcunifiles.com/icue/files/nbclearn/site/video/widget/NBC_Learn_Video_Widget.swf?VIDEO_ID=1280886</a>


Maybe it's because of the "?", but all I see is "Loading...". Can anyone suggest a solution?
Reality is merely an illusion, albeit a very persistent one - Albert Einstein

ggelsrinc

  • ASIF Citizen
  • Posts: 437
    • View Profile
Re: [Solved] How to embed a video ?
« Reply #27 on: October 30, 2013, 02:27:44 PM »
Not entirely [Solved], for flash at least. I just tried embedding a .SWF for the first time as follows:

<a href="http://icue.nbcunifiles.com/icue/files/nbclearn/site/video/widget/NBC_Learn_Video_Widget.swf?VIDEO_ID=1280886" target="_blank" class="new_win">http://icue.nbcunifiles.com/icue/files/nbclearn/site/video/widget/NBC_Learn_Video_Widget.swf?VIDEO_ID=1280886</a>


Maybe it's because of the "?", but all I see is "Loading...". Can anyone suggest a solution?


I can change my security settings to medium in my IE 10.0.9200.16618 browser and see the video content, if I give it permission to show all contents per page. I can make everybody's video appear and disappear by changing my settings, except your "loading" and what Neven posted. Neven's is a total blank space outlined in white and yours will be loading forever, as I see it.

I'm going to log off and reset my security settings with updates for all software potentially involved, after I try another fix. My IE does not like https, so don't take it personally.

 

ggelsrinc

  • ASIF Citizen
  • Posts: 437
    • View Profile
Re: [Solved] How to embed a video ?
« Reply #28 on: October 30, 2013, 08:45:56 PM »
I signed up to the https site and get a security certificate warning requiring me to give permission whenever I change pages that contains other content besides text. I always figured it was because the security certificate was issued for the http site, because it says the certificate was issued to another address.

I can see videos that are properly installed, if I quickly give permission.

I don't know if that information is helpful, because I figured everybody would know that by experiencing the same thing, if they were using the https address. IIRC, I think I chose it, because it was easier to sign up, based on information from ASIB.

When I use the http address, I don't have to give permission to see videos. 
« Last Edit: October 30, 2013, 09:26:57 PM by ggelsrinc »

Jim Hunt

  • ASIF Governor
  • Posts: 3106
    • View Profile
    • The Arctic sea ice Great White Con
Re: [Solved] How to embed a video ?
« Reply #29 on: October 30, 2013, 09:26:47 PM »
Thanks for checking ggelsrinc.

I figure there must be a problem of some sort with Simple Machines support for Flash videos, which is the common denominator between Neven's example and mine.
Reality is merely an illusion, albeit a very persistent one - Albert Einstein

ggelsrinc

  • ASIF Citizen
  • Posts: 437
    • View Profile
Re: [Solved] How to embed a video ?
« Reply #30 on: October 30, 2013, 09:38:54 PM »
When I deleted the s in the https address, it eliminated that certificate/permission problem, so videos just pop up if properly posted.

I overwrote the new http address in my favorites for the site.

Artful Dodger

  • ASIF Citizen
  • Posts: 436
  • The era of procrastination is coming to a close.
    • View Profile
Re: [Solved] How to embed a video ?
« Reply #31 on: December 29, 2016, 11:22:34 PM »
Testing embedded YouTube sample video:

[youtube]g6PV7Rvr7KU[/youtube]


RESULT: doesn't seem to be working.  :-[
Cheers!
Lodger