Support the Arctic Sea Ice Forum and Blog

Author Topic: Firefox is blocking the Arctic Sea Ice Forum  (Read 5154 times)

Xulonn

  • New ice
  • Posts: 40
    • View Profile
  • Liked: 1
  • Likes Given: 1
Firefox is blocking the Arctic Sea Ice Forum
« on: March 17, 2016, 04:21:31 PM »
While reading new replies this morning, Firefox suddenly decided to block my return to the unread replies page as an "HTTPS" site.  It was the familiar "connection is not secure" error, but now the option to override or bypass the error is no longer there. 

Firefox then would not allow me to access the main page as well   I got around the problem by removing the "S" and loading as "HTTP"

Why are there problems with the Arctic Sea Ice Forum HTTPS security certificates?

folke_kelm

  • New ice
  • Posts: 61
    • View Profile
  • Liked: 1
  • Likes Given: 0
Re: Firefox is blocking the Arctic Sea Ice Forum
« Reply #1 on: March 17, 2016, 07:16:59 PM »
That is strange, i use firefox and have never had any problems.

sidd

  • First-year ice
  • Posts: 5764
    • View Profile
  • Liked: 806
  • Likes Given: 0
Re: Firefox is blocking the Arctic Sea Ice Forum
« Reply #2 on: March 17, 2016, 07:24:37 PM »
firefox is working for me, for now

Revillo

  • New ice
  • Posts: 27
    • View Profile
  • Liked: 1
  • Likes Given: 0
Re: Firefox is blocking the Arctic Sea Ice Forum
« Reply #3 on: March 17, 2016, 08:12:02 PM »
The security error notice would go away for everyone if the link to the forum from the sea ice graphs page was changed from:

https://forum.arctic-sea-ice.net/

to

http://forum.arctic-sea-ice.net/

It would be nice if neven, or whever maintains it, could get around to repairing the link.

Neven

  • Administrator
  • First-year ice
  • Posts: 7778
    • View Profile
    • Arctic Sea Ice Blog
  • Liked: 1143
  • Likes Given: 537
Re: Firefox is blocking the Arctic Sea Ice Forum
« Reply #4 on: March 17, 2016, 10:08:10 PM »
Yes, there's a problem with the security certificate because the forum isn't hosted on a private server. It would work there, but that would make things much slower, more work, etc.

If I'd had to do it again, I'd leave the forum under http only, and forget about https, but it is supposed to be safer wrt privacy and malware etc.

Either way, there is no problem with the forum's security (AFAIK), so either let Firefox make an exception, or access the forum through http.
Il faut comparer, comparer, comparer, et cultiver notre jardin

Neven

  • Administrator
  • First-year ice
  • Posts: 7778
    • View Profile
    • Arctic Sea Ice Blog
  • Liked: 1143
  • Likes Given: 537
Re: Firefox is blocking the Arctic Sea Ice Forum
« Reply #5 on: March 17, 2016, 11:51:46 PM »
The security error notice would go away for everyone if the link to the forum from the sea ice graphs page was changed from:

https://forum.arctic-sea-ice.net/

to

http://forum.arctic-sea-ice.net/

It would be nice if neven, or whever maintains it, could get around to repairing the link.

Now that's something I can do. Thanks for the tip. Good idea.
Il faut comparer, comparer, comparer, et cultiver notre jardin

sidd

  • First-year ice
  • Posts: 5764
    • View Profile
  • Liked: 806
  • Likes Given: 0
Re: Firefox is blocking the Arctic Sea Ice Forum
« Reply #6 on: March 18, 2016, 04:00:42 AM »
I like having https and i am glad you offer it.

Revillo

  • New ice
  • Posts: 27
    • View Profile
  • Liked: 1
  • Likes Given: 0
Re: Firefox is blocking the Arctic Sea Ice Forum
« Reply #7 on: March 18, 2016, 05:02:21 AM »
The security error notice would go away for everyone if the link to the forum from the sea ice graphs page was changed from:

https://forum.arctic-sea-ice.net/

to

http://forum.arctic-sea-ice.net/

It would be nice if neven, or whever maintains it, could get around to repairing the link.

Now that's something I can do. Thanks for the tip. Good idea.

You're most welcome, and thanks for patching it.

Xulonn

  • New ice
  • Posts: 40
    • View Profile
  • Liked: 1
  • Likes Given: 1
Re: Firefox is blocking the Arctic Sea Ice Forum
« Reply #8 on: March 22, 2016, 03:08:13 PM »
I was able to track down the problem for my laptop - Windows 7 running the free Avast virus + internet security application. 

The problem wasn't just with the Firefox browser - it occurred with Chrome as well.  It turned out to be an Avast HTTPS scanning issue.  I disabled HTTPS scanning by Avast, and everything works again.   

Here's a link to the Avast settings tweak from Firefox: 

https://support.mozilla.org/en-US/questions/1104863


Neven

  • Administrator
  • First-year ice
  • Posts: 7778
    • View Profile
    • Arctic Sea Ice Blog
  • Liked: 1143
  • Likes Given: 537
Re: Firefox is blocking the Arctic Sea Ice Forum
« Reply #9 on: March 22, 2016, 11:02:01 PM »
I'm glad you found what caused the problem, Xulonn. I initially thought that the problem was just a security warning (that can be ignored).

Coincidentally, my computer also runs on Win7, I use Firefox and Avast, but I can't remember if I've ever had this problem.
Il faut comparer, comparer, comparer, et cultiver notre jardin