Support the Arctic Sea Ice Forum and Blog

Author Topic: Forum authentication broken  (Read 314 times)

kynde

  • ASIF Lurker
  • Posts: 17
    • View Profile
  • Liked: 2
  • Likes Given: 29
Forum authentication broken
« on: June 22, 2019, 09:16:18 PM »
Some recent changes in forum softwate has changed the authentication so that my mobile is forced to log in all the time. The session id seems to have changed from cookie to PHPSESSID querystring parameter and to make matters worse it does not validate anymore after few hours of inactivity.

I used to just keep the index url without any querystring params open in one tab and I was always good to go to read the new threads after a reload. The changes is apparent since in spite of  me lurking about I do come in here daily and have done so for quite some time.

Any chance there's been an upgrade in forum software or settings?

oren

  • ASIF Governor
  • Posts: 3915
    • View Profile
  • Liked: 536
  • Likes Given: 1111
Re: Forum authentication broken
« Reply #1 on: June 22, 2019, 11:21:56 PM »
I use this URL to browse the forum from my phone with no trouble.
https://forum.arctic-sea-ice.net/index.php?action=unread
IIRC there was some issue with logging in in two different locations (home? login screen?) but only one of them actually worked correctly.

Neven

  • Administrator
  • ASIF Royalty
  • *****
  • Posts: 6955
    • View Profile
    • Arctic Sea Ice Blog
  • Liked: 509
  • Likes Given: 355
Re: Forum authentication broken
« Reply #2 on: June 23, 2019, 12:29:11 PM »
If this is a problem for more people, I'll ask DungeonMaster to look into it (but he's very busy).
Il faut comparer, comparer, comparer, et cultiver notre jardin

gerontocrat

  • ASIF Royalty
  • Posts: 5438
    • View Profile
  • Liked: 724
  • Likes Given: 18
Re: Forum authentication broken
« Reply #3 on: June 23, 2019, 03:13:43 PM »
If this is a problem for more people, I'll ask DungeonMaster to look into it (but he's very busy).
It happened JUST ONCE on my phone and laptop (both on google).
I was logged off though usually use the "forever" choice on login.
So I logged in and no problems since.
"Para a Causa do Povo a Luta Continua!"
"And that's all I'm going to say about that". Forrest Gump
"Damn, I wanted to see what happened next" (Epitaph)

Pmt111500

  • ASIF Upper Class
  • Posts: 1776
    • View Profile
  • Liked: 42
  • Likes Given: 11
Re: Forum authentication broken
« Reply #4 on: June 23, 2019, 03:52:54 PM »
Accidentally clicking logout is possible, I've done it several times.
Amateur observations of Sea Ice since 2003.

kynde

  • ASIF Lurker
  • Posts: 17
    • View Profile
  • Liked: 2
  • Likes Given: 29
Re: Forum authentication broken
« Reply #5 on: June 25, 2019, 11:04:45 PM »
This happened to me many times and the URL was clearly different over those few days, _but_ it's gone now and login works as expected. Might be a regression they downgraded or fixed.